koulab

技術系のメモ

laravel/uiがLaravel6で入らない

解決策:バージョンを指定する

composer require laravel/ui 1.*
>composer require laravel/ui
Using version ^2.0 for laravel/ui
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Conclusion: remove laravel/framework v6.18.16
    - Conclusion: don't install laravel/framework v6.18.16
    - laravel/ui 2.x-dev requires illuminate/support ^7.0 -> satisfiable by laravel/framework[7.x-dev], illuminate/support[7.x-dev, v7.0.0, v7.0.1, v7.0.2, v7.0.3, v7.0.
4, v7.0.5, v7.0.6, v7.0.7, v7.0.8, v7.1.0, v7.1.1, v7.1.2, v7.1.3, v7.10.0, v7.10.1, v7.10.2, v7.10.3, v7.11.0, v7.12.0, v7.13.0, v7.2.0, v7.2.1, v7.2.2, v7.3.0, v7.4.0,
 v7.5.0, v7.5.1, v7.5.2, v7.6.0, v7.6.1, v7.6.2, v7.7.0, v7.7.1, v7.8.0, v7.8.1, v7.9.0, v7.9.1, v7.9.2].
    - laravel/ui v2.0.0 requires illuminate/support ^7.0 -> satisfiable by laravel/framework[7.x-dev], illuminate/support[7.x-dev, v7.0.0, v7.0.1, v7.0.2, v7.0.3, v7.0.4
, v7.0.5, v7.0.6, v7.0.7, v7.0.8, v7.1.0, v7.1.1, v7.1.2, v7.1.3, v7.10.0, v7.10.1, v7.10.2, v7.10.3, v7.11.0, v7.12.0, v7.13.0, v7.2.0, v7.2.1, v7.2.2, v7.3.0, v7.4.0,
v7.5.0, v7.5.1, v7.5.2, v7.6.0, v7.6.1, v7.6.2, v7.7.0, v7.7.1, v7.8.0, v7.8.1, v7.9.0, v7.9.1, v7.9.2].
    - laravel/ui v2.0.1 requires illuminate/support ^7.0 -> satisfiable by laravel/framework[7.x-dev], illuminate/support[7.x-dev, v7.0.0, v7.0.1, v7.0.2, v7.0.3, v7.0.4
, v7.0.5, v7.0.6, v7.0.7, v7.0.8, v7.1.0, v7.1.1, v7.1.2, v7.1.3, v7.10.0, v7.10.1, v7.10.2, v7.10.3, v7.11.0, v7.12.0, v7.13.0, v7.2.0, v7.2.1, v7.2.2, v7.3.0, v7.4.0,
v7.5.0, v7.5.1, v7.5.2, v7.6.0, v7.6.1, v7.6.2, v7.7.0, v7.7.1, v7.8.0, v7.8.1, v7.9.0, v7.9.1, v7.9.2].
    - laravel/ui v2.0.2 requires illuminate/support ^7.0 -> satisfiable by laravel/framework[7.x-dev], illuminate/support[7.x-dev, v7.0.0, v7.0.1, v7.0.2, v7.0.3, v7.0.4
, v7.0.5, v7.0.6, v7.0.7, v7.0.8, v7.1.0, v7.1.1, v7.1.2, v7.1.3, v7.10.0, v7.10.1, v7.10.2, v7.10.3, v7.11.0, v7.12.0, v7.13.0, v7.2.0, v7.2.1, v7.2.2, v7.3.0, v7.4.0,
v7.5.0, v7.5.1, v7.5.2, v7.6.0, v7.6.1, v7.6.2, v7.7.0, v7.7.1, v7.8.0, v7.8.1, v7.9.0, v7.9.1, v7.9.2].
    - laravel/ui v2.0.3 requires illuminate/support ^7.0 -> satisfiable by laravel/framework[7.x-dev], illuminate/support[7.x-dev, v7.0.0, v7.0.1, v7.0.2, v7.0.3, v7.0.4
, v7.0.5, v7.0.6, v7.0.7, v7.0.8, v7.1.0, v7.1.1, v7.1.2, v7.1.3, v7.10.0, v7.10.1, v7.10.2, v7.10.3, v7.11.0, v7.12.0, v7.13.0, v7.2.0, v7.2.1, v7.2.2, v7.3.0, v7.4.0,
v7.5.0, v7.5.1, v7.5.2, v7.6.0, v7.6.1, v7.6.2, v7.7.0, v7.7.1, v7.8.0, v7.8.1, v7.9.0, v7.9.1, v7.9.2].
    - Can only install one of: laravel/framework[7.x-dev, v6.18.16].
    - don't install illuminate/support 7.x-dev|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.0.0|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.0.1|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.0.2|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.0.3|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.0.4|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.0.5|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.0.6|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.0.7|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.0.8|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.1.0|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.1.1|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.1.2|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.1.3|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.10.0|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.10.1|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.10.2|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.10.3|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.11.0|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.12.0|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.13.0|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.2.0|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.2.1|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.2.2|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.3.0|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.4.0|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.5.0|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.5.1|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.5.2|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.6.0|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.6.1|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.6.2|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.7.0|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.7.1|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.8.0|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.8.1|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.9.0|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.9.1|don't install laravel/framework v6.18.16
    - don't install illuminate/support v7.9.2|don't install laravel/framework v6.18.16
    - Installation request for laravel/framework (locked at v6.18.16, required as ^6.2) -> satisfiable by laravel/framework[v6.18.16].
    - Installation request for laravel/ui ^2.0 -> satisfiable by laravel/ui[2.x-dev, v2.0.0, v2.0.1, v2.0.2, v2.0.3].


Installation failed, reverting ./composer.json to its original content.

https://qiita.com/daisu_yamazaki/items/a914a16ca1640334d7a5